工事情報
PostgreSQL 9.5(db9)のバージョンアップについて(終了)
2023年9月8日 18時11分
日時2023年9月27日 01時00分 ~ 2023年9月27日 02時30分
対象サービス全てのサービス をご利用のお客様
具体的影響

ご提供中のPostgreSQL 9.5(SQLアカウント名がdb9から始まる)は9月27日にPostgreSQL 13にバージョンアップいたします。

現行のPostgreSQL 9.5のデータベースにつきましては9月27日(水)のメンテナンスでPostgreSQL13への一括バージョンアップを行います。作業時間は次のとおりです。

  • 作業日時 2023年9月27日 01:00〜02:30
  • 作業の間PostgreSQL 9.5(db9〜)のデータベースはアクセスできません

バージョンアップ後の設定変更は必要ございませんが仕様の違いによる不具合にご注意ください

一括バージョンアップではこれまでのデータベース接続情報(データベースサーバ名、アカウント名など)を引き継ぎますのでお客様プログラムでこれらを変更していただく必要はございません。

  • バージョンアップ後にお客様プログラムの動作確認をお願いいたします。
  • 仕様の違いによりプログラムの修正が必要になる場合があります。

9月27日のバージョンアップ以後は旧バージョンに戻すことはできません

仕様の違いによりお客様のプログラムが正常に動作しなくなる可能性もありますのでPostgreSQL 9.5をお使いのお客様におかれましては、できるだけお客様での事前移行によるプログラムの動作確認・修正をお勧めいたします。

新しいバージョンのSQLデータベースに移行するための移行ツールがご利用いただけます

古いデータベースから新しいデータベースへの移行はコントロールパネルの管理者メニュー「SQL管理」のSQLデータベース一覧の下にデータ移行ツールへのリンクがございます。

  • MySQL移行ツール
  • PostgreSQL移行ツール

移行ツールをご利用の前に、移行元データベースのアカウント名、パスワードをご確認いただき、移行先の新しいデータベースを作成してご利用ください。

EC-CUBEでPostgreSQLをご利用の場合はバージョンにご注意ください

EC-CUBEでの対応PostgreSQLのバージョンはEC-CUBE自体のバージョンで違いがあります。

  • EC-CUBE 2系 PostgreSQL 9.x or higher (おそらくPostgreSQL 13は非対応)
  • EC-CUBE 3系 PostgreSQL 8.4〜9.x
  • EC-CUBE 4系 PostgreSQL 9.6〜14.x
  • EC-CUBE 2、3系をご利用の場合はEC-CUBE自体のバージョンアップやMySQLへのデータベース変更が必要になる可能性がございます。
※PostgreSQL→MySQLへの移行ツールはご用意しておりません。

備考サービスの停止は 01:19 〜 01:30 までの10分ほどでした。
最新情報 障害情報
ご案内
2024年1月12日 15時27分
対象:全てのサービス
重要なお知らせ
2020年7月1日 11時40分
対象:全てのサービス
重要なお知らせ
2014年3月17日 00時00分
対象:全てのサービス
販売パートナーについて
サイト内検索

▲ このページトップへ